Gallery not showing in IE or Firefox!?

edited January 2007 in Troubleshooting
I just downloaded and installed the app, but the thumbnails are not showing up. I've tested in both IE7 and Firefox with no avail. I've got version v09b65. It's running on an IIS server (see PHP test link below). I'm new to PHP, so maybe I'm missing something here.

I have changed the permissions on both /galleries and /cache to 777. /config/settings.php has default values.

Test PHP:

Please help!


  • edited January 2007
    apparently it dies when asking the gateway for the thumbnails. it seems the gateway sends some information, but then it just chokes. let me see what i can do, since i don't have neither experience nor access to a IIS server to test, hence the problems.

    as for the browsers, i don't think it is a browser-related issue, but a php thing. you have php 5.0.4 and i test locally on php 5.0.4 so i guess that shouldn't be the problem, but the IIS.

    i don't really know how permissions work on IIS, i have heard that on IIS you don't assign them, it is just not possible. could be that, though.

    if i find out something i'll let you know here.
  • Thanks! Can you tell if my server has the correct GD/GD2 installed? I didn't see that on the test.php anywhere. I don't think that matters for this error, but I have tried it with thumbnails both on and off, but I'm just curious.
  • I am having the exact same problem.

    I am using Php 4.1.2 with the following in the Commands:'--with-gd' '--enable-gd-native-ttf' '--with-ttf' '--with-gdbm'

    It does not matter if I leave the "." or put my URL in the mimishowcase_url settings.
    Thumbnail degug shows nothing if I turn it on.
    Debug in general does not show anything significant either.

    Any help would be appreciated

  • I´m having the exact same problem but on a Linux server.

    I just updated from a older version and now I can't get the new one to work.

    Test PHP:

    Would apreciate some help.
  • Victor, for your reference, I installed the previous version (v08b92).

    One this one, the gallery box loads, but the thumbnails don't. Hopefully this will help debug the issue with the new version.
  • I just read in another discussion that this problem can be a result of "safe_mode on"

    took a look at it and apparently the server i'm running it on has "safe_mode on"
  • My safe_mode is off, so I think we can rule that out in this case.

    Just as a side note, I am running the latest version of WordPress on my site with no problems.
  • Hi vistor, greeting from a pana venezolano ;). I'm having the exact same problem:

    The thumbnails does not appear when I click on the Gallery.
    I'm running PHP 4.4.4 in Apache in Safe_Mode Off
    chache and galleries directories are set to 777



    I've tried with or without thumbnails in the settings.php and nothing is happening. What can it be?
  • Well I solved it for myself, I tried everything and then I found out that the issue was caused by the galleries and thumbnails sorting.

    The default value in the settings.php file is 2 & 6 respectively. I changed both to 0 since it was the default server behavior and after that, everything went fine. I leave the code

    $settings['gallery_sorting'] = 0;
    $settings['thumbnail_sorting'] = 0;

    Hope that this will help somebody here.

    Great job Victor, keep it coming. People like you make me feel proud of my countrymen. Arepa de chigüire para ti!.

    I take this change to invite you all to my site: a place to notice all those people who parks like real jerks!
  • webjac314 thanks for sharing that, it fixed it on my server as well. I had tried everything including compiling php as a fastcgi binary + installing lighttpd on another port to eliminate apache as the cause.
  • Thanks, webjac314! I also switched to a Linux server from a windows box and solved a lot more problems!!!!!!! Too many to list here!
  • hi there,

    i'm sorry i've been off for a while, but "busyness" called.

    thanks to webjac314 for stepping in and saving the day. i like that this forum is becoming more of a community than a support center. at the end, your help makes the product a better one, for everybody.

    so to the point:

    1) i'll check the sorting system (again) and come up with a solution as soon as i can (top on the to-do list).

    2) IIS servers (windows) are somehow in the way of being unsupported due to my impossibility to test on one right now. if anyone can donate a share and ftp account to a directory on one IIS server, that would be great, and support could be reinstalled normally.

    btw, has anyone on a windows server tried with the option 6 = EXIF date sorting (for thumbnails)? it might work and it is by far the most precise and representative of them all (imho).

    glad things are working out. i'll post here once i've figured out the sorting issue (subscribe to this thread if you want to be informed of any advancement)
  • Thanks to webjac314 I have had some partial success.

    The thumbnails seem to be being generated but only the placeholder (for a brokem link) is shown. When a thumbnail placeholder is clicked on, the actual full size image is displayed. The slideshow works too. The thumbnail pictures do not show at all.

    Any ideas, anyone?

  • could you share a link so i can check it? that'll help a lot. if you don't feel like posting it here, e-mail it at minishowcase at frwrd dot net.
  • no problem, here it is:

    I also wonder if it is possible to have sub folders so as to be able to organise galleries into groups with a group name?

  • edited January 2007
    do you have the GD libraries installed?

    subgalleries are underway, it just takes longer to deal with the bugs in order to have a stronger, more stable gallery.
  • thanks webjac314 - putting the settings to 0 and 0 worked a dream :)
  • @everybody that has and will post here:

    could you tell me if you're on a windows server? i have heard some cases that were, but i'm not sure if this happens just on IIS servers.

    it will greatly help if you post your full configuration here, so i can try to reproduce the problem (sice i am unable to do so):
    1. Server software (IIS/windows, apache/linux/unix, others)
    2. PHP version (sort of 4.x.x, not just 4)
    3. GD libraries version (again, with subversions)
    4. Any changes in the settings.php file (or include it if changes are extensive)
    or perhaps you prefer to save your test.php (as per the instructions) as an html file and send it to me (including your community nickname) to minishowcase at frwrd dot net.

    that will help a lot, thanks (i want this bug to go away, it is ruining minishowcase's reputation as the easiest gallery around! hehe)
  • Well PHP had GD support enabled and there appreard to be some sort of GD version installed. However I installed GD2.0.33 and after a reboot ran the following script

    header ("Content-type: image/png");
    $img_handle = ImageCreate (230, 20) or die ("Cannot Create image");
    $back_color = ImageColorAllocate ($img_handle, 0, 10, 10);
    $txt_color = ImageColorAllocate ($img_handle, 233, 114, 191);
    ImageString ($img_handle, 31, 5, 5, "My first Program with GD", $txt_color);
    ImagePng ($img_handle);

    And it produced a graphical output with text.

    However still no thumbnails are being generated.

    And I had such high hopes!

    To see what PHPINFO says:

    Any help much appeciated.
  • i'll check on it, but as noted on the instructions and read me files, the oldest version of PHP supported is PHP 4.2.0, so it might be that.

    also, try generating a jpeg image, just to discard bad jpg from your GD.

    i'll let you know here.
  • Yes, the php is a bit old I know - I need to update my server but need a another computer to get it set up on as its a production machine.

    OK, I altered the image type to JPEG and it created a jpeg image OK.

    I'm running this under Linux (SME Server v6.0.1) This version was recently made obsolete so I will upgrade eventually.

  • Well thanks everybody for all the thanking, I'm here just to help (and get helped some times :D), as soon as some final solution comes up i'll be implementing it!.
  • edited April 2008
    i have a problem aswell with my thumbnails. they don't show up, but they did it for some time. if installed gd lib and it worked well so far. but since some days the thumbnails are not coming up anymore.
    is there any help for me?


  • edited June 2009
    your thumbnails give me this error:

    Warning: imagejpeg() [function.imagejpeg]: SAFE MODE Restriction in
    effect. The script whose uid is 10013 is not allowed to access /var/www/vhosts/its-
    DM Mittel owned by uid 30 in /var/www/vhosts/
    ol/httpdocs/minishowcase/libraries/thumb.display.php on line 217

    unfortunately SAFE MODE, which is a PHP setting on your server, is not supported by minishowcase. try contacting your hosting company and asking them about turning SAFE MODE off.
  • Hi there I have a question I have the gallery v09b148 it is working fine in both IE and firefox the only problem is that when opening in firefox (3.0.8) OS Windows XP I'm seeing this message before the gallery is opened
    [DEBUG] Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv: Gecko/2009032609 Firefox/3.0.8 FirePHP/0.2.4

    click to dismiss...

    « back to thumbnails
    [ 8] | pause slideshow

    Any ideas about the reason why I'm seeing this
  • Here is the image of what I see
  • edited June 2009
    i am having the exact same issue as mkiredjian but with absolutely no css styling.

    [DEBUG] Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv: Gecko/2009060215 Firefox/3.0.11 (.NET CLR 3.5.30729)

    My OS - Win XP
    Server - Linux CentOS
    Minishowcase - v09b142
    Browsers - IE7 & FF 3.0.11
    Website - http:// ipigals. com/ minishowcase/
    any ideas?
  • Do you have debugging on?

    Have you made ANY changes to the code? ANY?

  • debugging is set to false (all 3) i did not change anything in code as far as debugging.
    ONLY change to code i made was to add the absolute url of index.php file to the settings.php file.

    i have installed and uninstalled a few times with same result.

  • oh wow i just figured it out. it was my fault.

    when i first entered the absolute url of index.php file to the settings.php file i put it in the correct place. but when i went to the page to view it on the internet i went to
    http:// ipigals. com/ minishowcase/galleries. (not realizing my mistake) so i changed where i put the path on the settings page to the wrong place.

    i read earlier in another post that the correct url to the gallery is actually http:// xxxx. com/ minishowcase. in fact you say in that post u did not mention the correct path cuz you thought it was obvious. it's not. well at least not for me.

    it just occurred to me my error. i have fixed and am good to go thanks

    GREAT piece of work thq and thx for your help also
Sign In or Register to comment.