Navigation thumbnails not showing

edited January 2012 in Troubleshooting
Hi.
I installed the minishowcase both; locally on my iMAC 10.6.4 with MAMP and on the server. It's fantastic working and really easy to handle, great showcase.

The only issu I see now is online, the smaller thumbnails of the navigation bar (above the large images) don't show and a missing icon is shown instead. no idea why that would be. I have plenty of other images, etc with other script and no problems, so I can't think that this will be any problem with the GD...

Thanks a lot
Tagged:

Comments

  • do you have GD installed on your server? which version?
  • edited October 2012
    Hello, was a solution ever found for this issue? I am also having an issue with the nav bar thumbnails not showing (but the image names do show). This occurs on the slideshow bar only.

    My GD info is: gd
    GD Support enabled
    GD Version bundled (2.0.34 compatible)
    FreeType Support enabled
    FreeType Linkage with freetype
    FreeType Version 2.4.3
    GIF Read Support enabled
    GIF Create Support enabled
    JPEG Support enabled
    libJPEG Version 6b
    PNG Support enabled
    libPNG Version 1.2.46
    WBMP Support enabled
    XBM Support enabled

    Your help is most appreciated! Thanks!
  • It seems minishowcase is not supported by MAMP, might be a path issue. Sorry.
  • edited January 2013
    I am having this issue as well... my server is Apache 2.2.23, though, not Mac. I don't see the images in the nav bar above the images.

    Some of my thumbnails are not generating correctly either... not sure why, looking into it.

    http://collietails.com/camgallery/


    Edit:... hmm getting an error..
    Deprecated: Function split() is deprecated in ../camgallery/libraries/thumb.display.php on line 204

    Perhaps that is relevant.. I'll have to look at it in more detail tomorrow.
  • @Cynthiablue: check if your files are uploaded correctly (20120109g.jpg is not).
  • I'll add that patch to the next release, thanks Cynthiablue for your help!
  • edited February 2013
    @Cynthiablue By the way, you can just open ../camgallery/libraries/thumb.display.php, go to line 204 and change "split()" for "explode()", it'll work fine. (Promise it won't explode, hehe).
  • Hello. I would like to ask how to do, to showing navigation thumbnails uder php, newer than 5.3.2 relase. There are only filenames displayed. Thx for some help.
  • Hi @martt222 Please read and follow the community guidelines to post your issue, so we can better help you.
  • Hi, I am experiencing the same problem as @rkgusman last October. My site is hosted by a third party but I have obtained the following from the site. 

    My GD info is: gd
    GD Support enabled
    GD Version bundled (2.0.34 compatible)
    FreeType Support enabled
    FreeType Linkage with freetype
    FreeType Version 2.2.1
    GIF Read Support enabled
    GIF Create Support enabled
    JPEG Support enabled
    libJPEG Version 6b
    PNG Support enabled
    libPNG Version 1.2.14
    WBMP Support enabled
    XBM Support enabled

    I'm not sure of your comment re MAMP support applies to me.

    My minishowcase address is http://www.traveljourneys.com.au/minishowcase/

    I hope you can point me in the right direction. Thanks.

     

  • Seems your server memory might be the culprit. Contact your server administrator and ask them about it.
  • edited November 2013

    Hi everyone :-h

    I'm currently evaluating minishowcase v09b155. (Of course I'll purchase a license, if I keep using it.)

    This is how the URLs of the broken navigation thumbnails look like, …

    /minishowcase/libraries/thumb.display.php?max=30&sq=1&pr=1&img=cache/cache_test/th_photo.jpg

    … and here's the error message inside the files:

    Strict Standards:  Only variables should be passed by reference in /minishowcase/libraries/thumb.display.php on line 205

    Warning:  Cannot modify header information - headers already sent by (output started at /minishowcase/libraries/thumb.display.php:205) in /minishowcase/libraries/thumb.display.php on line 221

    CREATOR: gd-jpeg v1.0 (using IJG JPEG v62), quality = 80

    The last line is obviously just the comment in the JFIF header of the (malformed) image.

    I understand that one workaround would be to use Slimbox or ThickBox, but I'd like to get the default preview (with thumb navigation) to work.



    Output of phpinfo():
    PHP Version: 5.4.21
    System: Linux infong 2.4 #1 SMP Mon Aug 5 20:05:43 CEST 2013 i686 GNU/Linux
    Build Date: Oct 18 2013 08:43:37

    GD Support: enabled
    GD Version: bundled (2.1.0 compatible)
    FreeType Support: enabled
    FreeType Linkage: with freetype
    FreeType Version: 2.4.2
    GIF Read Support: enabled
    GIF Create Support: enabled
    JPEG Support: enabled
    libJPEG Version: 6b
    PNG Support: enabled
    libPNG Version: 1.2.44
    WBMP Support: enabled
    XBM Support: enabled

    Directive: gd.jpeg_ignore_warning (Local Value: 0 / Master Value: 0)
  • this is a php.ini error and is not related to minishowcase. check with your hosting company or relate to your php.ini file.

    if you send me the gallery url i might be able to help you more.
Sign In or Register to comment.