Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Google Sign In with OpenID

In this Discussion

cache images not working

edited December 2009 in Troubleshooting
I've set the configuration variables in settings.php so that both thumbnails and images are cached as scaled versions. Using the '../?thumbnails' request, all thumbnails are created in the appropriate cache directory. The scaled thumbnails have "th_" appended to the filename in the cache directory. I do not see any filenames appended with "img_" OR "cache_"

As a work around, I'd like to know the command that creates a thumbnail in the cache directory. I should be able to find a way to build a manually run shell script that will create the scaled images and write them to the appropriate cache directory. What does that command look like assuming I have read in the variables from settings.php for appropriate image conversion values.

Or could it be explained why images are not scaled and cached correctly? Thank you

Comments

  • your images won't be cached unless they're bigger than the selected min size. they'll be saved on the same folder the thumbnails are.

    only command available to cache thumbs/images is manually calling the /galleries/?thumbnails. if you know javascript you can check the code and write your own javascript call.

    good luck
  • Thanks. I forgot to mention that the original images are significantly greater in size than the selected min size. Which javascript file in the minishowcase directory tree does the thumbnail caching?
  • Any reason that the scaled images are not being processed correctly since they are not being cached as expected? Any tips for troubleshooting this?
  • with the information you're providing it would be impossible for me to know, as i don't know enough about your install, your server, or most of the information that the guidelines ask you to provide for us to be able to help you.

    please read the guidelines and post accordingly. i know life is fast, but if you don't take the time to help us help you, then we might not either.
  • Oops. sorry. I'm using the latest minishowcase which is available at this site.
    Apache/2.2.9 (Debian) PHP/5.2.6-1
    Debian Linux (Lenny)

    I looked through the settings.php file and I don't see a min size setting. Only $settings['cache_image_size'] = 800;
    All original images are larger than this either by width or height

    It looks like the php is using the gd functions. gd is a library. I can't specifically call it from command line like I could with imagemagick.

    I also found that the password file is not controlling access to galleries. I used the default from the settings.php file (password) and created a file named password.php with only two lines, line 1 with user and line 2 with password. I move this file to different locations starting from a default install of minishowcase starting at /webdocs/[SITE]/photos/galleries/
    This is not an issue for me because I can use htdigest/htpasswrd and Apache to secure the galleries
  • strangely the cache_image_size is working on my computer minishowcase install as supposed. it will cache only images that are longer/wider than the amount specified in their largest side. if you provide a url to your gallery i can check it.

    password features are completely unsupported and offered AS IS, but they should work as stated in the
    settings.php
    file, that is, as a .php (password.php by default). no username is needed as clearly stated in the instructions on the settings.php file.
  • http://www.cdne.net/photos/ember/
    user/pass: victor/victor
    goto 2009->December
    You'll see the thumbs come up fast because they are cached :-)
    Viewing one of the images has a delay
    I could use imagemagick to create the scaled versions and drop them into the appropriate cache directory tree.
  • you have
    $settings['scale_big_images']
    set to
    true
    which cancels caching mode (as you're saying you want them to shrink not to be resized)

    also, check your
    $settings['minishowcase_url']
    as it is not pointing to the right place (you might leave it empty unless you're following the iframe embedding instructions)
  • OK, thanks. I set to false which speeds up the delivery of the image, however, no cache files are created. I'm happy with this. Thanks for taking a look. I'll leave your access in place for a bit if you want to have another look at why the cache files are not being created correctly.
  • After stepping away and pulling the galleries from a remote connection, not local LAN, The images take a long time to load. Let's figure out why we're not creating local cache copies of images in the same way as the thumbnails.
  • have you tried with smaller images? php might be getting out of memory while processing them.
Sign In or Register to comment.