Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Google Sign In with OpenID

In this Discussion

Thumbnails not showing up [Can't get it working :(]

edited January 2007 in Installing
Downloaded the latest version today.

Updated the config to set the base url. Set the cache dir permissions. Placed on a linux machine with PHP5 and GD installed. Everything runs ok with no errors to the page or the error_log, but the galleries don't display any thumbnails, this includes the Venezuela example. When you click a gallery, you see a very brief flash of a red border around an area I'd expect the thumbnails to be in, but then no thumbnails. It even creates the pagination for a lot of images, but no images!

If I turn on thumbnail caching, it creates the subdirectories appropriately in the cache folder, but with nothing in them.

Any ideas?

Comments

  • Play with the following 2 settings in the /config/settings.php file. You may have to experiement...


    /**** FILE CONFIG ***********************************************/


    /* Gallery menu and Thumbnail sorting (arranging)
    * Usage: Change the value to:
    * 0 : default platform sorting (check it on your platform)
    * 1 : natural sorting (0833.jpg comes before 2018.jpg)
    * 2 : natural sorting, case-insensitive (recommended)
    * 3 : reverse default platform sorting
    * 4 : reverse natural sorting
    * 5 : reverse natural sorting, case-insensitive
    * 6 : EXIF date (not tested thoroughly)
    * 7 : EXIF date (reverse order, not tested thoroughly) */
    $settings['gallery_sorting'] = 4; //2
    $settings['thumbnail_sorting'] = 0; //6
  • yes, this seemed to be an issue, it seems to be confirmed.

    i might have some time in the weekend, there are three issues pending:
    - sorting problems (seems to happen a lot on IIS servers)
    - gallery and image name encoding (for my polish, french and swedish friends)
    - the third is secret.

    hope to have them solved soon.

    please post here your experience with playing around with the sortings so i can know which ones work.

    also, and as stated in the guidelines, please post your browser, server software php and gallery version. without that there's very little i can do
  • two more things:

    @delanthear: next time please search for similar posts not to repeat and spread the information, this issue has been posted in other threads. help us help you faster and steadier.

    @kcornwell: thanks again for the help
  • @victor: Sorry. I did search and look through installing and troubleshooting and try a few things but none seemed to address this issue!

    @kcornwell: ooh! That's fixed it. Thank you. I just get broken images instead of thumbnails now, but I'm going to see if I can work out why.
  • Hi, im using IE 6, and FF 2, i have the latest version just downloaded today, and set up, the site link is found at (http://roblyneyriefarm.net/new/minishowcase_v09b73/index.php) im getting an error on the page [Notice: Undefined index: SCRIPT_FILENAME in C:\Accounts\roblyne1\wwwRoot\new\minishowcase_v09b73\libraries\general.init.php on line 10]
    im not sure why im getting this error, i have followed every step of the instalation to a T.

    attached i have a copy of my settings file too, in case this helps...?

    Any help would be great, thanks.
  • edited January 2007
    did you check all requirements? could you tell me your php version?

    SCRIPT_FILENAME is an index of the global _SERVER variable. it is very strange you don't have it active....

    and could you please open a new thread with the title describing your problem?
  • I can confirm experiencing the same symptoms described by the original poster DELANTHEAR on 1/25/07. My environment is Windows XP SP2, PHP 5.1.4 (w/GD2), Apache 2.0.54 and Firefox 2.0.0.1. I downloaded and installed the latest MiniShowcase zip on 2/14/2007. I adjusted the settings:
    $settings['gallery_sorting'] = 4; //2
    $settings['thumbnail_sorting'] = 0; //6
    per KCORNWELL and the thumbnails were created and showed up...
  • it is a big problem that i don't have the platform (Win IIS server, PHP4/5) to test and fix this issue, but i'll try to find a way to have it. in the meanwhile i'll be dealing with it from the PHP documentation.

    please feel free to post any improvement and information regarding it, as it will surely help me.

    thanks very much.
  • i've been unable to reprduce the situation, which impedes me from finding a solution. i am to put up a IIS server as now i have acces to a pc, and then i'll see what i can do.
  • I'm having this problem now. Minishowcase worked fine on my home server but not on my live one. Thumbnails are being created fine but just won't show up. The slideshow works fine however with the thumbnails at the top.

    Gallery: http://www.victoriahighlandersfc.com/media_photos.php
    Php info: http://www.victoriahighlandersfc.com/testing/phpinfo.php

    I've played around with the sorting settings and nothing...

    Help?!?!

    Thanks
  • mooger, please read and follow the guildelines (in the main discussions page) so we can help you properly.
  • First, is this the correct thread? There are a lot on thumbnails and I wasn't sure which one?

    Server is apache. I've tested both IE 6 and Firefox 3. The minishowcase version is the latest.
  • have you made changes to the gallery code? (including renaming the index.php file). i cannot help you as i don't know which changes you have made.

    if you really want us to help you, please take the time to explain all your case. if you don't find the time to help us help you, we won't find it either.
  • Sorry... here are some more details.

    Changes I have made to the code:

    1. I removed some of the if statements for the javacript as I wasn't using the other options any way. Output is:











    2. I added a strtoupper function to the menu title:



    3. I added the fix from RiX (http://minishowcase.net/community/comments.php?DiscussionID=231&page=1#Item_4). This was after I encounted the problem but it didn't fix it for me.


    My config settings:

    $settings['gallery_debug'] = false;
    $settings['javascript_debug'] = false;
    $settings['thumbnail_debug'] = false;


    $settings['use_select_menu'] = false;
    $settings['use_double_nav_menu'] = false;

    $settings['minishowcase_url'] = "http://victoriahighlandersfc.com/galleries";

    $settings['set_language'] = 'en';
    $settings['auto_set_language'] = true;

    $settings['password_filename'] = 'password';

    $settings['use_theme'] = 'default';
    $settings['square_thumbnails'] = true;
    $settings['max_thumbnails'] = 4;
    $settings['max_thumbnail_rows'] = 4;
    $settings['scale_big_images'] = true;
    $settings['thumbnail_quality'] = 70;
    $settings['preview_thumbnail_quality'] = 40;
    $settings['large_image_quality'] = 100;
    $settings['scroll_menu'] = false; /* DOES NOT CURRENTLY WORK */

    $settings['gallery_title'] = 'minishowcase | gallery';
    $settings['gallery_width'] = 650;
    $settings['gallery_default'] = false;
    $settings['gallery_default_name'] = 'Victoria_Highlanders_FC';
    $settings['show_permalink'] = false; /* MIGHT NOT BE VERY STABLE */
    $settings['gallery_footer'] = 'Powered by minishowcase and cpaint';

    $settings['info_file'] = '_info.txt';

    $settings['cache_images'] = true;
    $settings['cache_image_size'] = 800;
    $settings['create_thumbnails'] = true;
    $settings['cache_thumb_size'] = 128;
    $settings['mark_visited_thumbs'] = false;

    $settings['gallery_sorting'] = 4;
    $settings['thumbnail_sorting'] = 0;


    $settings['preview_mode'] = 1;

    $settings['set_double_encoding'] = false;

    $settings['gallery_name_prepend'] = '';
    $settings['gallery_name_append'] = 'pictures';

    $settings['number_galleries'] = false;
    $settings['show_gallery_number'] = false;
    $settings['show_thumb_name'] = false;
    $settings['show_thumb_number'] = false;
    $settings['numbered_blocks'] = true;

    $settings['slideshow_seconds'] = 5;

    $settings['hidden_files'] = array();
    $settings['hidden_files'][] = 'Thumbs.db';
    $settings['hidden_files'][] = '.DS_Store';


    $settings['allowed_extensions'] = array();
    $settings['allowed_extensions'][] = 'jpg';
    $settings['allowed_extensions'][] = 'jpeg';
    $settings['allowed_extensions'][] = 'png';
    $settings['allowed_extensions'][] = 'gif';


    As I said earlier... it worked on my home apache server but not on my host's. If you need more info, please let me know.

    Thanks

    Gallery: http://www.victoriahighlandersfc.com/media_photos.php
    Php info: http://www.victoriahighlandersfc.com/testing/phpinfo.php
  • edited June 2009
    if you click on the (slideshow) button in your gallery, you'll see the images. that makes me think you have either a javascript problem, or a tag ID naming problem.

    please make sure your IDs are not the same IDs minishowcase is using, specially the ones that start with "thumbs_"

    said that, it is difficult to know what's happening with all the code you added (there are several JS libraries, and CSS files wrapping the gallery. please set


    $settings['gallery_debug'] = false;
    $settings['javascript_debug'] = false;
    $settings['thumbnail_debug'] = false;


    all to TRUE on your
    /config/settings.php
    file and send me the link directly to
    info at minishowcase dot net
    (or whisper it in a comment to me)
  • also, try installing in a different folder a new, fresh version of minishowcase and see if it works. if it does, it is the code you add that breaks it.

    let me know.
  • It must be the code I added...

    Worked just fine on another try
    http://victoriahighlandersfc.com/minishowcase/minishowcase/

    The unfortunate thing is I need the other JS libraries for other things on the site. I figured it may be a conflict issue.

    Thanks for your help... I think I'm just going to build something simple on my own. Too bad, I really like your gallery.

    Jason
  • if you want send me the JS libraries and i might take a look, don't promise anything, but i'll keep you updated

    and thanks for the support
Sign In or Register to comment.